PTA乙级 1019 数字黑洞 (20分)--水题

题目原文

给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个 (0,104) 区间内的正整数 N

输出格式:

如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

输入样例 1:

6767

输出样例 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例 2:

2222

输出样例 2:

2222 - 2222 = 0000

题目大意

就是给你一个数(0-9999)然后让你用这个数字 个位,十位,百位,千位上的4个数字,组成一个最大的数,和一个最小的数.

然后它们相减. 相减后的数字如果是6174或者0就停止.

不然就一直这样继续.

我的思路:

就是用一个数组保存这4个数字,然后算出最大和最小.

然后一直循环.

我的代码:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
    int min = 0, max = 0,New;
    vector<int> inex;
    cin >> New;
    do{
    int t = 0;
    while (New) {
        t = New % 10;
        inex.push_back(t);
        New /= 10;
    }
    while (inex.size() != 4) {
        inex.push_back(0);
    }
    sort(inex.begin(), inex.end());
    min=0;
    min=inex[0]*1000+inex[1]*100+inex[2]*10+inex[3];
    max=inex[3]*1000+inex[2]*100+inex[1]*10+inex[0];
    New = max-min;
    printf("%04d - %04d = %04d\n",max,min,New);;
    inex.clear();
    }while(New!=0&&New%1111!=0&&New!=6174);
    return 0;
}

柳神的代码

#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(char a, char b) {return a > b;}
int main() {
    string s;
    cin >> s;
    s.insert(0, 4 - s.length(), '0');
    do {
        string a = s, b = s;
        sort(a.begin(), a.end(), cmp);
        sort(b.begin(), b.end());
        int result = stoi(a) - stoi(b);
        s = to_string(result);
        s.insert(0, 4 - s.length(), '0');
        cout << a << " - " << b << " = " << s << endl;
    } while (s != "6174" && s != "0000");
    return 0;
}

柳神的代码和我的差不多,不过比起我的代码,她的代码高度集成化.

猜你喜欢

转载自blog.csdn.net/Huangpengyu123/article/details/107091515