数字黑洞问题

问题

1069 The Black Hole of Numbers (20 分)
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10
4
).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
结尾无空行
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
结尾无空行
Sample Input 2:
2222
结尾无空行
Sample Output 2:
2222 - 2222 = 0000

思路

使用sprintf把每次的差值读入char数组。char类型-‘0’可得int。

代码

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int main(){
    
    
    int n,first,second,diff;
    scanf("%d",&n);
    diff = n;
    if(n == 6174)
        printf("7641 - 1467 = 6174\n");
    while (diff!=6174){
    
    
        char digtis[maxn]={
    
    '0'};
        sprintf(digtis,"%04d",diff);
        sort(digtis,digtis+strlen(digtis));
        first = (digtis[3]-'0')*1000+(digtis[2]-'0')*100+(digtis[1]-'0')*10+(digtis[0]-'0');
        second = (digtis[0]-'0')*1000+(digtis[1]-'0')*100+(digtis[2]-'0')*10+(digtis[3]-'0');
        diff = first - second;
        printf("%04d - %04d = %04d\n",first,second,diff);
        if(diff==0||diff==6174)break;
    }
    return 0;
}

总结

两个大坑:
1.超时问题,如果两个数相减等于0了,要break,不然死循环超时。
2.如果一开始输入的数就是6174要特判。

猜你喜欢

转载自blog.csdn.net/qq_19272233/article/details/119465616