1019-数字黑洞

给定任一个各位数字不完全相同的4位正整数,如果我们先把4个数字按非递增排序,再按非递减排序,然后用第1个数字减第2个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的6174,这个神奇的数字也叫Kaprekar常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089 9810 - 0189 = 9621 9621 - 1269 = 8352 8532 - 2358 = 6174 7641 - 1467 = 6174 ... ...

现给定任意4位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个(0, 10000)区间内的正整数N。

输出格式:

如果N的4位数字全相等,则在一行内输出“N - N = 0000”;否则将计算的每一步在一行内输出,直到6174作为差出现,输出格式见样例。注意每个数字按4位数格式输出。

输入样例1:
6767
输出样例1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例2:
2222
输出样例2:
2222 - 2222 = 0000
------------------------------------------------------------------------------
 
 
该题注意给数组每次赋为全零,否则会出现错误。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<stdio.h>

// 数字,每一位剥离出来,排序,组成新数,减法 
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;

int bo(int n)
{
   int a[5];
   memset(a,0,sizeof(a));
  int b=n;
  int i=0;
  while(b!=0)
  {
    a[i++]=b%10;
    b=b/10;
  }
  sort(a,a+4);
  int c1=0,c2=0;
  for(i=0;i<4;i++)
  {
    c1=c1*10+a[3-i];
  }
    for(i=0;i<4;i++)
  {
    c2=c2*10+a[i];
  }
  int div=c1-c2;
  printf("%04d - %04d = %04d",c1,c2,div);
  return div;
 } 
int main(int argc, char** argv) {
int n;
cin>>n;
int j;
if(n==0)
{
  cout<<"0000 - 0000 = 0000";
  return 0;
}
    while(1){
      j=bo(n);
      n=j;
       if(j==0||j==6174)
       break;
       cout<<endl;
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_32835707/article/details/62237647