1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

double p[1001];

int main()
{
    int k,exp;
    double coef;
    cin >> k;
    for(int i = 0; i < k; i++){
        cin >>exp>>coef;
        p[exp] += coef;
    }
    cin >> k;
    for(int i = 0; i < k; i++){
        cin >>exp>>coef;
        p[exp] += coef;
    }
    int cnt = 0;
    for(int i = 0; i < 1001; i++){
        if(p[i]!=0) cnt++;
    }
    printf("%d",cnt);
    for(int i = 1001; i >= 0; i--){
        if(p[i]!=0){
            printf(" %d %.1lf",i,p[i]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/89003530