【PAT 甲级】1002 A+B for Polynomials (25)(25 分)

题目链接
作者: CHEN, Yue
单位: PAT联盟
时间限制: 400ms
内存限制: 64MB
代码长度限制: 16KB

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ … NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2

思路:
多项式加法。
注意全为0和多项式的长度。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>

using namespace std;
const int N = 1e3+5;
double ans[N]={0.0};
int main()
{
    int n,i;
    double x;
    cin>>n;
    while(n--)
    {
        cin>>i;
        cin>>x;
        ans[i]+=x;
    }
    cin>>n;
    while(n--)
    {
        cin>>i>>x;
        ans[i]+=x;
    }
    int len=0;
    for(int i=0; i<=1000; i++)///别漏掉 =
    {
        if(ans[i]!=0.0)
        {
            len++;
        }
    }
    cout<<len;
    if(len)
    {
        cout<<" ";
        for(int i=1000; i>=0; i--)
        {
            if(ans[i]!=0.0)
            {
                printf("%d %.1f",i,ans[i]);
                len--;
                if(len) cout<<" ";
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/80849601