PAT (Advanced Level) Practice 1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

多项式加法。

注意当系数为0的时候需要剔除。

代码如下:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
int n,m;
struct pol 
{
	int zhi;
	double xi;
};
vector<pol>ans;
pol a[maxn],b[maxn];
int numa=0,numb=0;
int main()
{
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		int zhi;
		double xi;
		scanf("%d%lf",&zhi,&xi);
		if(xi!=0.0)
		{
			a[numa].zhi=zhi;
			a[numa++].xi=xi;
		}
	}
	scanf("%d",&m);
	for (int i=0;i<m;i++)
	{
		int zhi;
		double xi;
		scanf("%d%lf",&zhi,&xi);
		if(xi!=0.0)
		{
			b[numb].zhi=zhi;
			b[numb++].xi=xi;
		}
	}
	int i=0,j=0;
	while (i<numa||j<numb)
	{
		if((j>=numb)||(a[i].zhi>b[j].zhi))
		{
			pol x;
			x.zhi=a[i].zhi; x.xi=a[i].xi;
			ans.push_back(x);
			i++;
		}
		else if((i>=numa)||(b[j].zhi>a[i].zhi))
		{
			pol x;
			x.zhi=b[j].zhi; x.xi=b[j].xi;
			ans.push_back(x);
			j++;
		}
		else if(i<numa&&j<numb&&a[i].zhi==b[j].zhi)
		{
			pol x;
			x.zhi=a[i].zhi; x.xi=a[i].xi+b[j].xi;
			if(x.xi!=0.0)
				ans.push_back(x);
			i++; j++;
		}
	}
	printf("%d",ans.size());
	for (int i=0;i<ans.size();i++)
	{
		printf(" %d %.1lf",ans[i].zhi,ans[i].xi);
	}
	printf("\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/84869908