1002 A+B for Polynomials(多项式加法) (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Genius_panda_ACM/article/details/87897312

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题意

输入两排数字,每排数字有一个非零项个数输入(比如第一行的首个2表示这一行有两个非零项),然后1表示一次幂,2.4表示大小,0表示0次幂,3.2表示大小。

解题思路

详见代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
double A[12][3],B[12][3],sum[1001];
int main()
{
	int a,b,sum1=0,sum2=0;
	cin>>a;//a表示输入第一排非零项的数量
	for(int i=0;i<a;i++)
		cin>>A[i][0]>>A[i][1];//A[i][0]存幂的次数,A[i][1]存大小。
	cin>>b;//b表示输入第二排非零项的数量
	for(int i=0;i<b;i++)
		cin>>B[i][0]>>B[i][1];
	for(int i=0;i<a;i++)
		sum[int(A[i][0])]=sum[int(A[i][0])]+A[i][1];//相加操作
	for(int i=0;i<b;i++)
		sum[int(B[i][0])]=sum[int(B[i][0])]+B[i][1];//相加操作	
	for(int i=0;i<=1000;i++)//判断相加后有多少项并存入sum1中
		if(sum[i]!=0)
			sum1++;
	if(sum1!=0)
		cout<<sum1<<" ";
	else
		cout<<sum1;//如果sum1为0没有末尾空号。
	for(int i=1000;i>=0;i--)
	{
		if(sum[i]!=0)
		{
			printf("%d %.1f",i,sum[i]);
			sum2++;
			if(sum2!=sum1)
				printf(" ");
		}
		
	}			
	return 0;	
}

 

猜你喜欢

转载自blog.csdn.net/Genius_panda_ACM/article/details/87897312