1002 A+B for Polynomials (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42623428/article/details/83548966

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    double a[1001]={0};
    cin>>n;
    while(n--){
        int b;
        double c;
        cin>>b>>c;
        a[b]+=c;
    }
    cin>>n;
    while(n--){
        int b;
        double c;
        cin>>b>>c;
        a[b]+=c;
    }
    int cnt=0;
    for(int i=0;i<=1000;i++){
        if(a[i])cnt++;
    }
    cout<<cnt;
    if(cnt)cout<<" ";
    for(int i=1000;i>=0;i--){
        if(a[i]){
            cout<<i<<" ";
            printf("%.1lf",a[i]);
            cnt--;
            if(cnt)cout<<" ";
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_42623428/article/details/83548966