PAT Advanced 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 2 1.5 1 2.9 0 3.2


多项式的加减,实际用map进行存储即可

#include <iostream>
#include <map>
using namespace std;
int main()
{
    int M,coef,coun=2;
    double expo;
    map<int,double,greater<int>> m;//按照从大到小的顺序
    while(coun--){
        cin>>M;
        while(M--){
            cin>>coef>>expo;
            m[coef] += expo;
        }
    }
    for(auto it=m.begin();it!=m.end();it++)
        if(it->second==0) m.erase(it);
    cout<<m.size();
    for(auto it:m)
        printf(" %d %.1f",it.first,it.second);
    system("pause");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/12215686.html