PAT-A 1002. A+B for Polynomials (25)(25 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

作者: CHEN, Yue

单位: PAT联盟

时间限制: 400ms

内存限制: 64MB

代码长度限制: 16KB

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std; 
const int nmax=1005;
double a[nmax];//a[i]表示指数为i的项的系数 
double b[nmax];
double c[nmax];
int main(int argc, char** argv) {
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	memset(c,0,sizeof(c));
	int k1,k2;
	cin>>k1;
	int n;
    double e;
	for(int i=0;i<k1;i++){
		cin>>n>>e;
		a[n]=e;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
	   cin>>n>>e;
	   b[n]=e;
	} 
	int cnt=0;
	for(int j=0;j<nmax;j++){
		if(a[j]!=0||b[j]!=0){
			c[j]=a[j]+b[j]; 
		}
	}
	for(int i=0;i<nmax;i++){
		if(c[i]!=0){
			cnt++;
		}
	}
	cout<<cnt;
	for(int i =nmax-1; i >=0; i--){
        if(c[i] != 0){
            printf(" %d %.1f",i,c[i]);//在数字前面输出空格 
        }
    }
    printf("\n");

	return 0;
}
/*测试数据
4 4 0.5 2 5.6 1 -2.7 0 3.6
3 3 -2.1 2 -5.6 1 2.7 
*/

 只使用了1个数组

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std; 
const int nmax=1001;
double c[nmax];

int main(int argc, char** argv) {
	memset(c,0,sizeof(c));
	int t;
	double num;
    int k1,k2;
    cin>>k1;
    for(int i=0;i<k1;i++){
    	cin>>t>>num;
    	c[t]+=num;
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>t>>num;
		c[t]+=num;
	}
	int cnt=0;
	for(int j=0;j<nmax;j++){
		if(c[j]!=0){
			cnt++;
		}
	}
	cout<<cnt;
	for(int i=nmax-1;i>=0;i--){
		if(c[i]!=0){
			//cout<<" "<<i<<" "<<c[i]; //cout被奇奇怪怪地卡数据 
			printf(" %d %.1f",i,c[i]); //还是printf大法好 
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81165527