1002 A+B for Polynomials(25 分) PAT 甲级

版权声明:转载请注明出处及原文地址。 https://blog.csdn.net/zl1085372438/article/details/82597097

1002 A+B for Polynomials(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include <iostream>
#include <cstdio>
#include <cstring>
#include <list>
#include <algorithm>
#include <deque>

using namespace std;

struct DATA
{
    int e;
    double c;
};
typedef struct DATA DATA;
DATA a[20],b[20];
int lena,lenb;
DATA ans[100];
DATA res[100];


int main()
{
    scanf("%d",&lena);
    for(int i=0;i<lena;i++)
    {
        scanf("%d%lf",&a[i].e,&a[i].c);
    }
    scanf("%d",&lenb);
    for(int i=0;i<lenb;i++)
    {
        scanf("%d%lf",&b[i].e,&b[i].c);
    }
    int i=0;
    int j=0;
    int k=0;
    while(i<lena &&j<lenb)
    {
        if(a[i].e==b[j].e)
        {
            double cc=a[i].c+b[j].c;
            ans[k].c=cc;
            ans[k].e=a[i].e;
            k++;
            i++;
            j++;
        }
        else if(a[i].e>b[j].e)
        {
            ans[k].c=a[i].c;
            ans[k].e=a[i].e;
            k++;
            i++;
        }
        else
        {
            ans[k].c=b[j].c;
            ans[k].e=b[j].e;
            k++;
            j++;
        }
    }
    if(i<lena)
    {
        while(i<lena)
        {
            ans[k].c=a[i].c;
            ans[k].e=a[i].e;
            k++;
            i++;
        }
    }
    if(j<lenb)
    {
        while(j<lenb)
        {
            ans[k].c=b[j].c;
            ans[k].e=b[j].e;
            k++;
            j++;
        }
    }
    int id=0;
    for(int i=0;i<k;i++)
    {
        if(ans[i].c!=0)
        {
            res[id++]=ans[i];
        }
    }
    printf("%d",id);
    for(int i=0;i<id;i++)
    {
        printf(" %d %.1f",res[i].e,res[i].c);
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zl1085372438/article/details/82597097