PAT 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
注意: 
    1.map完美的数据结构    
    2.结果多项式中是不能输出系数为0的项的
    3.map的倒序输出
#include<iostream>
#include<map> 
using namespace std;

map<double,double> hashc;

int main(){

    int n;
    double zs,xs;  // zs:指数 xs:系数
    cin>>n;
    for (int i = 0; i < n; ++i){
        cin>>zs>>xs;    
        hashc[zs] += xs;
    }

    cin>>n;
    for (int i = 0; i < n; ++i){
        cin>>zs>>xs;
        hashc[zs] += xs;
    }  

    int cnt = 0;
    for (auto t:hashc){
        if (t.second)
            cnt++;
    }
    cout<<cnt;

    for (auto t = hashc.rbegin() ; t != hashc.rend(); ++t){
        if (t->second){
            cout<<" "<<t->first;
            printf(" %.1f",t->second);    
        }
    }
    return 0;
}
发布了423 篇原创文章 · 获赞 38 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/weixin_41514525/article/details/104827427