PAT 1002 A+B for Polynomials(25 分)

1002 A+B for Polynomials(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N 1   a N 1   N 2   a N 2 . . . N K   a N K
where K is the number of nonzero terms in the polynomial, N i ​and a N i (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1 K 10 , 0 N K < < N 2 < N 1 1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2




解析

这题有两个要注意的点:
①题目有:with the same format as the input
你的系数是浮点,且输出时只能有一位小数
② 两个指数相同时,它们系数的和可能是0.要注意这一点



Code:

#include<cstdio>
#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
{
    int N1, N2,temp1;
    double temp2;
    vector<pair<int, double>> plo1,plo2,result;
    cin >> N1;
    for (int i = 0; i < N1; i++) {
        cin >> temp1 >> temp2;
        plo1.push_back(make_pair(temp1,temp2));
    }
    cin >> N2;
    for (int i = 0; i < N2; i++) {
        cin >> temp1 >> temp2;
        plo2.push_back(make_pair(temp1, temp2));
    }
    int i=0, j=0;
    while (i < N1 && j < N2) {
        if (plo1[i].first > plo2[j].first)
            result.push_back(plo1[i++]);
        else if (plo1[i].first < plo2[j].first)
            result.push_back(plo2[j++]);
        else {
            if((plo1[i].second + plo2[j].second)!=0)
                result.push_back(make_pair(plo1[i].first, plo1[i].second + plo2[j].second));
            i++; j++;
        }
    }
    while (i < N1) 
        result.push_back(plo1[i++]);
    while (j < N2)
        result.push_back(plo2[j++]);
    cout << result.size();
    for (auto x : result)
        printf(" %d %.1f",x.first,x.second);
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82585295