1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 2 1.5 1 2.9 0 3.2

题解:用C++写了两次只通过了部分数据额,最后看别人的博客是用C语言来写的,确实,用C++来控制输入输出的格式不太好控制。

#include<iostream>

using namespace std;

int main() {
    float a[1001] = {0};
    int k;
    int exp;
    float coe;

    cin >> k;
    for(int i = 0; i < k; ++i) {
        cin >> exp >> coe;
        a[exp] += coe;
    }

    cin >> k;
    for(int i = 0; i < k; ++i) {
        cin >> exp >> coe;
        a[exp] += coe;
    }

    int count = 0;
    for (int i = 0; i < 1001; ++i) {
        if (a[i] != 0) count++;
    }

    cout << count;
    for (int i = 1000; i >= 0; --i) {
        if (a[i] > 0)
            cout << " " << i << " " << a[i];
    }

}

  

猜你喜欢

转载自www.cnblogs.com/ruruozhenhao/p/12104814.html