C++甲级1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include <iostream>
using namespace std;
int main()
{
	double v[1001] = {0.0};
	int n1,n2;
	int cnt = 0;
	int index;
	double coe;
	cin >> n1;
	for(int i = 0;i < n1;i++)
	{
		cin >> index >> coe;
		v[index] = coe;
	}
	cin >> n2;
	for(int i = 0;i < n2;i++)
	{
		cin >> index >> coe;
		v[index] += coe;
	}
	for(int i = 0;i < 1001;i++)
		if(v[i]!=0)
			cnt++;
	cout << cnt;
	for(int i = 1000;i >= 0;i--)
		if(v[i]!=0)
			printf(" %d %.1lf",i,v[i]);

	return 0;
}

做题这种事最消磨人的是看起来简单思路也都有,就是有毛病通不过。。。。烦银 

猜你喜欢

转载自blog.csdn.net/qq_37503890/article/details/87027249