1002 A+B for Polynomials (25)(25 分)

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题目解析

直接根据题的意思做就可以,模拟一下过程

#include <stdlib.h>
#include <stdio.h>
#include <malloc.h>
#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn = 1100;
int k;
double a[maxn];
int b[maxn],c[maxn];

int main()
{
    int x,tot = 1;
    double y;
    scanf("%d",&k);
    for(int i =0 ;i < k;i ++)
        scanf("%d%lf",&x,&y),a[x] += y,b[tot++] = x;
    scanf("%d",&k);
    for(int i =0 ;i < k;i ++)
        scanf("%d%lf",&x,&y),a[x] += y,b[tot++] = x;
    sort(b+1,b+tot);b[0] = -1;
    int num = 0;
    for(int i = 1;i < tot;i ++)
        if(b[i] != b[i-1] && a[b[i]] != 0)
            c[num++] = b[i];
    printf("%d",num);
    for(int i = num-1;i >= 0;i --)
        printf(" %d %.1lf",c[i],a[c[i]]);
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/81661169