PAT甲级1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include<stdio.h>

int main()
{
    int n1,n2,i,maxx=0,maxy=0;
    int x;float y;
    scanf("%d",&n1);
    float a[1001]={0};
    for(i=0;i<n1;i++)
    {
        scanf("%d%f",&x,&y);
        a[x]=y;
        if(x>maxx)
            maxx=x;
    }
    scanf("%d",&n2);
    float b[1001]={0};
    for(i=0;i<n2;i++)
    {
        scanf("%d%f",&x,&y);
        b[x]=y;
        if(x>maxy)
            maxy=x;
    }
    int num=(maxx>maxy?maxx:maxy)+1;int k=0;
    float c[num+1];
    for(i=0;i<num;i++)
    {
        c[i]=a[i]+b[i];
        if(c[i]!=0)
            k++;
    }
    printf("%d",k);
    for(i=num-1;i>=0;i--){
        if(c[i]!=0)
            printf(" %d %.1f",i,c[i]);
        }
    
}

   这道题第一遍做只对了一个测试点,得了13分,看了算法笔记的测试用例后才知道坑在哪,当两个表达式相同指数对应的系数相加和为零的时候(没有想到系数可以是负数),这一项就不需要输出了。还有一个错误点就是输出的格式问题,我的输出格式是空格在数字后输出,这样当出现消掉的项以后输出格式就有问题了,所以应该改成空格在数字前输出。

猜你喜欢

转载自blog.csdn.net/qq_38290604/article/details/86654326