1002 A+B for Polynomials (25 分)(简单的PAT甲级题目)

我要考甲级!!!

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码:(注意一点就是输出非零项!!)

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int index;
    double data;
} a[1005],b[1005],c[2005];
int f[1005];///标记数组。
bool compare(node a,node b)
{
    return a.index>b.index;
}
int main()
{
    int n,m;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d %lf",&a[i].index,&a[i].data);
    }
    scanf("%d",&m);
    int k = 0;
    for(int i=0; i<m; i++)
    {
        scanf("%d %lf",&b[i].index,&b[i].data);
        int j;
        for(j=0; j<n; j++)
        {
            if(b[i].index==a[j].index)
            {
                f[j] = 1;
                if(a[j].data + b[i].data > 0)///这里的>可以换成!=,只能说这个题目数据有点水。
                {
                    c[k].data = a[j].data + b[i].data;
                    c[k++].index = a[j].index;
                }
                break;///跳出的话表示找到了。
            }
        }
        if(j==n)///没有跳出,表示没有a[],和b[]没有重复的元素。
        {
            c[k++] = b[i];
        }
    }
    for(int i=0; i<n; i++)
    {
        if(f[i]==0)
        {
            c[k++] = a[i];
        }
    }
    sort(c,c+k,compare);///用sort函数排序。
    if(k==0)///这里需要注意,0的时候单独输出。
    {
        printf("0\n");
        return 0;
    }
    printf("%d ",k);
    for(int i=0; i<k; i++)
    {
        printf(i==k-1?"%d %.1lf\n":"%d %.1lf ",c[i].index,c[i].data);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/ACMerdsb/article/details/83548146