剪格子 蓝桥杯

                                                       剪格子  

         时间限制:1.0s   内存限制:256.0MB

题目链接:http://lx.lanqiao.cn/problem.page?gpid=T27

问题描述

如下图所示,3 x 3 的格子中填写了一些整数。

+--*--+--+
|10* 1|52|
+--****--+
|20|30* 1|
*******--+
| 1| 2| 3|
+--+--+--+

我们沿着图中的星号线剪开,得到两个部分,每个部分的数字和都是60。

本题的要求就是请你编程判定:对给定的m x n 的格子中的整数,是否可以分割为两个部分,使得这两个区域的数字和相等。

如果存在多种解答,请输出包含左上角格子的那个区域包含的格子的最小数目。

如果无法分割,则输出 0。

输入格式

程序先读入两个整数 m n 用空格分割 (m,n<10)。

表示表格的宽度和高度。

接下来是n行,每行m个正整数,用空格分开。每个整数不大于10000。

输出格式

输出一个整数,表示在所有解中,包含左上角的分割区可能包含的最小的格子数目。

样例输入1

3 3
10 1 52
20 30 1
1 2 3

样例输出1

3

样例输入2

4 3
1 1 1 1
1 30 80 2
1 1 1 100

样例输出2

10

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define mem(a) memset(a,0,sizeof(a))
#define maxn 100
using namespace std;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int vis[20][20]={0};
int a[20][20];
int m,n;
int s=0;
int ans=0;
bool flag=0;
bool cc(int x,int y)
{
    if(vis[x][y]==0)
     if(x<n&&x>=0)
      if(y<m&&y>=0)
        return 1;
    return 0;
}
void dfs(int x,int y,int sum)
{
    ans++;
    if(sum==s)
    {
        if(!flag)
            cout<<ans<<endl;
        flag=1;
        return ;
    }
    vis[x][y]=1;
    for(int i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(cc(xx,yy)&&sum+a[xx][yy]<=s)
            dfs(xx,yy,sum+a[xx][yy]);
    }
    ans--;
    vis[x][y]=0;
    return ;
}
int main()
{
    cin>>m>>n;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            cin>>a[i][j];
            s+=a[i][j];
        }
    if(s%2!=0)
        cout<<"0"<<endl;
    else
    {
        s=s/2;
        dfs(0,0,a[0][0]);
        if(!flag)
            cout<<"0"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Septembre_/article/details/84554769