Power Strings

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

 Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

 For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

 This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1000005
int main()
{
  int num[N];
  char s[N];
  int n,i;
  while(scanf("%s",s),s[0]!='.')// 逗号表达式代替 if break
  {
     int j = -1;//j 表示前缀,i 表示后缀
     num[0] = -1;
     n = strlen(s);
     for(i=0;i<n;)
     {
        if(j == -1||s[i] == s[j])num[++i] = ++j;
        else j = num[j];
     }
     if(n%(n-num[n])==0)  //解决特例 aabaabaa abcabcabc(符合条件)
     printf("%d\n",n/(n-num[n]));
     else puts("1");

  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/problemlife/article/details/81529771