PAT (Advanced Level) Practice 1117

1117 Eddington Number(25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number",E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题意是找到最大的天数E,使得那天骑行的距离小于天数即可

#include<cstdio>
#include<algorithm>
using namespace std;
int arr[100010];
bool cmp(int a, int b){
	return a > b;
}
int main(){
	int n;
	scanf("%d", &n);
	for(int i = 0;i < n;i++){
		scanf("%d", &arr[i]);
	}
	sort(arr, arr + n, cmp);
	int c = 0;
	while(c < n && arr[c] > c + 1){
		c++;
	}
	printf("%d", c);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/a568283992/article/details/82494394