PAT (Advanced Level) Practice 1117 Eddington Number(25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82251524

1117 Eddington Number(25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题意:找到最大的数E,使得有E天riding超过E;

思路:排序后,从n向下遍历,用upper_bound()找第一个超过i天的下标,求比i大的数的数量。

代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int main()
{
    int n;scanf("%d",&n);
    int a[maxn]={0};
    int m=0;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        m=max(m,a[i]);
    }
    sort(a,a+n);
    int ans=0;
    for(int i=n;i>=0;i--)
    {
        int pos=upper_bound(a,a+n,i)-a;
        //printf("pos=%d\n",pos);
        if(i<=(n-pos)){
            ans=i;
            break;
        }
    }
    printf("%d\n",ans);

}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82251524