PAT (Advanced Level) Practice 1004

1004 Counting Leaves (30)(30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

思路:就是计算最大深度,然后判断每一层的叶子个数即可。

#include<cstdio>
#include<string>
#include<queue>
using namespace std;



struct Node{
	int level;//当前级别 
	int num;//当前节点孩子个数 
	int child[110];	//存储孩子节点 
}T[110];

int levelCount[110];
queue<int> q;


int main(){
	int N, M, maxLevel = 0;
	scanf("%d %d", &N, &M);
	char node[3];
	for(int i = 0;i < M;i++){
		scanf("%s", node);
		int t, root;
		scanf("%d", &t);
		sscanf(node, "%d", &root);
		for(int j = 0;j < t;j++){
			int n;
			scanf("%s", node);
			sscanf(node, "%d", &n);
			T[root].child[T[root].num++] = n;
		}
	}
	q.push(1);
	while(!q.empty()){
		int pos = q.front();
		q.pop();
		if(T[pos].num == 0){
			levelCount[T[pos].level]++;
		}else{
			for(int i = 0;i < T[pos].num;i++){
				T[T[pos].child[i]].level = T[pos].level + 1;
				q.push(T[pos].child[i]);
				maxLevel = max(maxLevel, T[T[pos].child[i]].level);
			}	
		}
	}
	
	for(int i = 0;i <= maxLevel;i++){
		if(i == maxLevel){
			printf("%d", levelCount[i]);
		}else{
			printf("%d ", levelCount[i]);
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a568283992/article/details/81984785