PAT (Advanced Level) Practice 1117 Eddington Number (25分)

1.题目

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

2.代码

#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
int list[100001];
int main()
{
	int n,i;
	cin >> n;
	for ( i = 1; i<=n; i++)
		cin >> list[i];
	sort(list+1, list + n+1, greater<int>());
	for ( i = 1; i <= n; i++)
		if (i >= list[i]) { cout << i - 1 << endl; return 0; }
	cout << i-1;
}
发布了204 篇原创文章 · 获赞 4 · 访问量 5689

猜你喜欢

转载自blog.csdn.net/qq_42325947/article/details/105262395