PAT (Advanced Level) Practice 1076

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

分析:需要计算在规定层数下所遍历的最多节点。用BFS来遍历,便于计算层数。在将起点入队后,每次将队列中的所有元素取出作为数组,之后以数组元素为起点将所有可到达的点入队,重复此过程直到满足层数要求或队空,每进行一次上述过程便将层数+1。最后输出所有遍历过的点的个数即为答案。

代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#define MAXN 1001
using namespace std;
int G[MAXN][MAXN] = { 0 };
int visit[MAXN] = { 0 };
int N, L, K;
void bfs(int start) {
	int numPerson = 0;
	int level = 0;
	queue<int> q;
	q.push(start);
	visit[start] = 1;
	while (q.empty() == false && level < L) {
		int top[MAXN];
		int size = q.size();
		int index = 0;
		for (int i = 0; i < size; i++) {
			top[index++] = q.front();
			q.pop();
		}
		for (int i = 0; i < index; i++) {
			for (int v = 1; v <= N; v++) {
				if (G[top[i]][v] == 1 && visit[v] == 0) {
					q.push(v);
					visit[v] = 1;
					numPerson++;
				}
			}
		}
		level++;
	}
	cout << numPerson << endl;
	fill(visit, visit + MAXN, 0);
}
int main() {
	cin >> N >> L;
	for (int u = 1; u <= N; u++) {
		int M;
		cin >> M;
		for (int i = 0; i < M; i++) {
			int v;
			cin >> v;
			G[v][u] = 1;
		}
	}
	cin >> K;
	for (int i = 0; i < K; i++) {
		int id;
		cin >> id;
		bfs(id);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82823507
今日推荐