PAT (Advanced Level) Practice 1034

1034 Head of a Gang (30 分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

分析:求所有连通分量的节点个数与对应边权最大的和的节点head的编号。用map存储节点名和节点编号的映射关系。在DFS进行的过程中,需要记录连通分量的节点个数、边权和与head节点编号,用&来传参。每到新节点处使节点个数+1,并判断head节点是否需要变更。之后,在求边权和后需要需要让边权归零,防止走回头路。

代码: 

#include<iostream>
#include<algorithm>
#include<vector>
#include<map>
#include<string>
#define MAXN 2002
#define INF 0x3fffffff
using namespace std;
int G[MAXN][MAXN];
int totalTime[MAXN] = { 0 };
int visit[MAXN] = { 0 };
map<string, int> stringToInt;
map<int, string> intToString;
int N, K;
int numPerson = 0;
map<string, int> gang;
void dfs(int u, int &head, int &tempNum, int &tempSum) {
	tempNum++;
	visit[u] = 1;
	if (totalTime[u] > totalTime[head]) {
		head = u;
	}
	for (int v = 0; v < numPerson; v++) {
		if (G[u][v] != 0) {
			tempSum += G[u][v];
			G[u][v] = G[v][u] = 0;
			if (visit[v] == 0) {
				dfs(v, head, tempNum, tempSum);
			}
		}
	}
}
void dfs() {
	for (int u = 0; u < numPerson; u++) {
		if (visit[u] == 0) {
			int head = u, tempNum = 0, tempSum = 0;
			dfs(u, head, tempNum, tempSum);
			if (tempNum > 2 && tempSum > K) {
				gang[intToString[head]] = tempNum;
			}
		}
	}
}
int getID(string s) {
	if (stringToInt.count(s) == 1) {
		return stringToInt[s];
	} else {
		stringToInt[s] = numPerson;
		intToString[numPerson] = s;
		return numPerson++;
	}
}
int main() {
	fill(G[0], G[0] + MAXN * MAXN, 0);
	cin >> N >> K;
	getchar();
	for (int i = 0; i < N; i++) {
		string name1, name2;
		int time;
		cin >> name1 >> name2 >> time;
		int id1 = getID(name1);
		int id2 = getID(name2);
		G[id1][id2] += time;
		G[id2][id1] += time;
		totalTime[id1] += time;
		totalTime[id2] += time;
	}
	dfs();
	cout << gang.size() << endl;
	for (auto it = gang.begin(); it != gang.end(); it++) {
		cout << it->first << ' ' << it->second << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82822784