PAT (Advanced Level) Practice 1140

1140 Look-and-say Sequence(20 分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

根据题意就是显示几个数,下面就用自然数描述上一次的数即可。

如:1、11、21...表示1、1个1、2个1

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;
int main(){
	string s = "";
	int n;
	cin>>s>>n;
	for(int i = 1;i < n;i++){
		string p = "";
		int len = s.size();
		char be_c = s[0];
		int pos = 0;
		for(int j = 1;j <= len;j++){
			if(j == len){
				p += be_c;
				p += (j - pos + '0');
			}else if(be_c != s[j]){
				p += be_c;
				p += (j - pos + '0');
				pos = j;
				be_c = s[j];
			}
		}
		s = p;
	}
	cout<<s<<endl;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/a568283992/article/details/82250576