PAT (Advanced Level) Practice 1013

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

分析:考察的是连通分量的知识点。求在去除一个节点后,加入几条边能使剩下的各分量重新成为连通图。因为将不相连的连通分量连接起来所需的边数量为连通分量数量减一,因此求连通分量即可得结果。

若要求取连通分量个数,使用DFS。因为一次DFS可遍历整个连通图,所以可根据DFS执行的次数来判断连通分量的个数。在使用DFS前,要将输入的concern点设为已访问,表示去除此点。由此可得到最后结果。

代码:

#include<iostream>
#include<algorithm>
#define MAXN 1001
#define INF 0x3fffffff
using namespace std;
int N, M, K;
int G[MAXN][MAXN];
int visit[MAXN] = { 0 };
void dfs(int start) {
	visit[start] = 1;
	for (int i = 1; i <= N; i++) {
		if (visit[i] == 0 && G[start][i] != INF) {
			dfs(i);
		}
	}
}
int main() {
	fill(G[0], G[0] + MAXN * MAXN, INF);
	cin >> N >> M >> K;
	for (int i = 0; i < M; i++) {
		int u, v;
		scanf("%d %d", &u, &v);
		G[u][v] = G[v][u] = 1;
	}
	for (int i = 0; i < K; i++) {
		fill(visit, visit + MAXN, 0);
		int temp;
		int cnt = 0;
		cin >> temp;
		visit[temp] = 1;
		for (int j = 1; j <= N; j++) {
			if (visit[j] == 0) {
				dfs(j);
				cnt++;
			}
		}
		cout << cnt - 1 << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82719742