PAT (Advanced Level) Practice 1001

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 分析:简单的字符串处理,注意输出为0的情况

 代码:

#include<iostream>
#include<cmath>
#include<string>
using namespace std;
int main() {
	string A, B;
	cin >> A >> B;
	int a = atoi(A.c_str());
	int b = atoi(B.c_str());
	int c = a + b;
	string C = "";
	int index = 0;
	int temp = abs(c);
	while (temp != 0) {
		if (index == 3) {
			C = ',' + C;
			index = 0;
		}
		index++;
		C = (char)(temp % 10 + '0') + C;
		temp /= 10;
	}
	if (c < 0) {
		C = '-' + C;
	}
	if (C.size() > 0) {
		cout << C << endl;
	}else {
		cout << '0' << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82714888