PAT (Advanced Level) Practice 1067

1067 Sort with Swap(0, i)(25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

 使用贪心算法,分2种,0在原来位置和0不在。

如果0不在,那么以0角标元素为基础,不断和对应位置交换,直到出现0为止。

如果0在,那么需要检索下目前的元素,是否存在还没调整的,如果存在和0进行交换,然后重复上述步骤。

#include <cstdio>
int arr[100010];
void swap(int &a, int &b){
	int t = a;
	a = b;
	b = t;
}
int main() {
    int n, c = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
    	scanf("%d", &arr[i]);
    }
    for(int i = n - 1;i >= 0;i--){
    	while(arr[0] != 0){
			swap(arr[0], arr[arr[0]]);
			c++;
		}
    	if(i != arr[i]){
    		swap(arr[0], arr[i]);
    		c++;
    	}
    }
    printf("%d", c);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a568283992/article/details/82353997
今日推荐