PAT (Advanced Level) Practice 1002

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

分析:数组长度要设到1000。在录入输入数值后,将对应下标的值相加。之后将非零的项的数目,项与下标输出即可。

代码: 

#include<iostream>
#include<vector>
#define MAXN 1001
using namespace std;
int main() {
	int K;
	int N;
	vector<double> N1(MAXN), N2(MAXN);
	cin >> K;
	for (int i = 0; i < K; i++) {
		cin >> N;
		cin >> N1[N];
	}
	cin >> K;
	for (int i = 0; i < K; i++) {
		cin >> N;
		cin >> N2[N];
	}
	vector<double> ans(MAXN);
	K = 0;
	for (int i = 0; i < MAXN; i++) {
		ans[i] = N1[i] + N2[i];
		if (ans[i] != 0) {
			K++;
		}
	}
	cout << K;
	for (int i = MAXN - 1; i >= 0; i--) {
		if (ans[i] != 0) {
			printf(" %d %.1lf", i, ans[i]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82715193
今日推荐