PAT (Advanced Level) Practice 1018

1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

分析:本题除了需要记录最短路径,还需要另外两个标尺来衡量路径:除最短路径外,优先满足送出车辆最少,若送出量相同则满足带回车辆最少。。由于最短路径不唯一且标尺关系较复杂,用Dijkstra + DFS算法比较清晰方便。在录入点权的时候将点权减去perfect量的值,在后续DFS计算中直接将标尺量与经过处理的点权作运算,不断找出带回与送出的最小值,最终求得解。

代码:

#include<iostream>
#include<algorithm>
#include<vector>
#define MAXN 501
#define INF 0x3fffffff
using namespace std;
int G[MAXN][MAXN];
int C[MAXN];
int d[MAXN];
int visit[MAXN] = { 0 };
int Cmax, N, Sp, M;
vector<int> pre[MAXN];
vector<int> path, tempPath;
int minBack = INF, minNeed = INF;
void dfs(int v) {
	tempPath.push_back(v);
	if (v == 0) {
		int back = 0, need = 0;
		for (int i = tempPath.size() - 1; i >= 0; i--) {
			int index = tempPath[i];
			if (C[index] > 0) {
				back += C[index];
			}else {
				if (-C[index] > back) {
					need += -C[index] - back;
					back = 0;
				}else {
					back += C[index];
				}
			}
		}
		if (need < minNeed) {
			minNeed = need;
			minBack = back;
			path = tempPath;
		}else if (need == minNeed && back < minBack) {
			minBack = back;
			path = tempPath;
		}
		tempPath.pop_back();
		return;
	}
	for (int i = 0; i < pre[v].size(); i++) {
		dfs(pre[v][i]);
	}
	tempPath.pop_back();
}
void dijkstra() {
	fill(d, d + MAXN, INF);
	d[0] = 0;
	for (int i = 0; i <= N; i++) {
		int u = -1, minN = INF;
		for (int j = 0; j <= N; j++) {
			if (d[j] < minN && visit[j] == 0) {
				u = j;
				minN = d[j];
			}
		}
		if (u == -1) {
			return;
		}
		visit[u] = 1;
		for (int v = 0; v <= N; v++) {
			if (visit[v] == 0 && G[u][v] != INF) {
				if (d[v] > d[u] + G[u][v]) {
					d[v] = d[u] + G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}else if (d[v] == d[u] + G[u][v]) {
					pre[v].push_back(u);
				}
			}
		}
	}
}
int main() {
	fill(G[0], G[0] + MAXN * MAXN, INF);
	cin >> Cmax >> N >> Sp >> M;
	for (int i = 1; i <= N; i++) {
		int temp;
		cin >> temp;
		C[i] = temp - Cmax / 2;
	}
	for (int i = 0; i < M; i++) {
		int u, v, w;
		cin >> u >> v >> w;
		G[u][v] = G[v][u] = w;
	}
	dijkstra();
	dfs(Sp);
	cout << minNeed << ' ';
	for (int i = path.size() - 1; i >= 0; i--) {
		if (i != 0) {
			cout << path[i] << "->";
		}else {
			cout << path[i] << ' ';
		}
	}
	cout << minBack << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/82749665