PAT (Advanced Level) Practice 1043

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

分析:题目大意:首先输入二叉树节点个数,接着输入一组数据,若此组数据的序列为一颗BST的先序序列或BST镜像数的先序序列,则输出“YSE”并输出其后序序列;否则输出“NO”。所谓镜像树,指的是构成规律与BST完全相反的树。

开始的时候打算分别构建BST与其镜像树并取得其先序序列,然后比较序列判断得到结果。然后发现镜像树其实并不需要构建,只需要对BST进行一个“先右后左”的先序遍历即可。对于镜像树的输入序列同理。因此只需一个先序序列与一个镜像先序序列即可。

需要注意的两点:①如果把vector作为函数参数且需改变vector内的值,则在定义时需要为Vector加入&符号。

                           ②这里BST的插入操作,如果存在与插入值相同的数值,不需要额外的操作。

(这题改了两个小时……devcpp的调试不好用只能各种cout找问题,最后发现是复制粘贴preorder改成preorderMirror的时候忘把递归语句的函数名也改了……简直崩溃……)

代码:

#include<iostream>
#include<vector>
using namespace std;
struct BST{
	int data;
	BST *left;
	BST *right;
};
vector<int> pre, mirror, org, post;
BST *newNode(int x)
{
	BST *root = new BST;
	root->data = x;
	root->left = root->right = NULL;
	return root;
}
void insert(BST* &root, int x)
{
	if(root == NULL){
		root = newNode(x);
		return;
	}
	if(x < root->data){
		insert(root->left, x);
	}else{
		insert(root->right, x);
	}
}
BST *creat(vector<int> &vi, int n)
{
	BST *root = NULL;
	for(int i = 0; i < vi.size(); i++){
		insert(root, vi[i]);
	}
	return root;
}
void preorder(BST *root, vector<int> &vi)
{
	if(root == NULL){
		return;
	}
//	cout << root->data << endl;
	vi.push_back(root->data);
//	if(root->left != NULL)
//		cout << root->data << "->" << root->left->data << endl;
//	if(root->right != NULL)
//		cout << root->data << "->" << root->right->data << endl;
//	cout << "============" << endl;
	preorder(root->left, vi);
	preorder(root->right, vi);
}
void preorderMirror(BST *root, vector<int> &vi)
{
	if(root == NULL){
		return;
	}
//	cout << root->data << endl;
	vi.push_back(root->data);
//	if(root->left != NULL)
//		cout << root->data << "->" << root->left->data << endl;
//	if(root->right != NULL)
//		cout << root->data << "->" << root->right->data << endl;
//	cout << "============" << endl;
	preorderMirror(root->right, vi);
	preorderMirror(root->left, vi);
}
//void preorder2(BST *root)
//{
//	if(root == NULL){
//		return;
//	}
//	cout << root->data << endl;
//	if(root->left != NULL)
//		cout << root->data << "->" << root->left->data << endl;
//	if(root->right != NULL)
//	cout << root->data << "->" << root->right->data << endl;
//	cout << "============" << endl;
//	preorder2(root->left);
//	preorder2(root->right);
//}
void postorder(BST *root, vector<int> &vi)
{
	if(root == NULL){
		return;
	}
	postorder(root->left, vi);
	postorder(root->right, vi);
	vi.push_back(root->data);
}void postorderMirror(BST *root, vector<int> &vi)
{
	if(root == NULL){
		return;
	}
	postorderMirror(root->right, vi);
	postorderMirror(root->left, vi);
	vi.push_back(root->data);
}
int camp(vector<int> va, vector<int> vb)
{
	int flag = 1;
	for(int i = 0; i < va.size(); i++){
		if(va[i] != vb[i]){
			flag = 0;
			break;
		}
	}
	return flag;
}
int main()
{
	int n;
	cin >> n;
	for(int i = 0; i < n; i++){
		int temp;
		cin >> temp;
		org.push_back(temp);
	}
	BST *T, *MT;
	T = creat(org, n);
//	MT = creatMirror(org, n);
//	preorder2(MT);
//	cout << "------------" << endl;
//	preorder(T, pre);
//	cout << "============@" << endl;
//	preorder(MT, mirror);
//	cout << "============@" << endl;
//	for(int i = 0; i < mirror.size(); i++){
//		cout << org[i] << endl;
//	}
//	cout << "============" << endl;
	preorder(T, pre);
	preorderMirror(T, mirror);
	int flag = camp(org, pre) || camp(org, mirror);
	if(flag == 1){
		cout << "YES" << endl; 
		if(camp(org, mirror)){
			postorderMirror(T, post);
		}else{
			postorder(T, post);
		}
		for(int i = 0; i < n; i++){
			if(i != n - 1){
				cout << post[i] << ' ';
			}else{
				cout << post[i] << endl;
			}
		}
	}else{
		cout << "NO" << endl;
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/g28_gwf/article/details/79969134
今日推荐