PAT (Advanced Level) Practice 1064

1064 Complete Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 题意就是,给你一个序列,让你创建出一个完全二叉树形式的二叉排序树。

思路就是,先排序,排序后的结果就是这个完全二叉树的中序遍历,所以根据完全二叉树的特点,我们可使用区间折半查找的方式来找每一层的根节点。

#include<cstdio>
#include<cstdlib>
#include<vector>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int arr[1010];
struct D{
	int l, r;
	D(int l, int r):l(l), r(r){}
};
vector<int> v;
queue<D> q;
int n;
//使用折半区间的方式进行层次遍历 
void binaryIntervals(){
	q.push(D(0, n - 1));//对整个区间进行,找到根节点 
	while(!q.empty()){
		D d = q.front();
		q.pop();
		int l = d.l, r = d.r;
		if(l == r){//区间是一样的,直接放入数组即可 
			v.push_back(arr[l]);
			continue; 
		} 
		int total = r - l + 1; //当前元素个数 
		double min_pow = log(total + 1)/log(2);//当前左右都满的情况下层数 
		int base = pow(2, (int)min_pow);//下一层的可放元素个数 
		int half = base / 2;//左右两边平均 
		int reminder = total - base + 1;//剩余的元素个数
		int index = -1;
		if(reminder <= half){
			index = r - (base - 2) / 2;//得到当前元素的角标 
		}else{
			index = r - ((base - 2) / 2 + (reminder - half));
		}
		//printf("--> %d %d [%d,%d]\n", index, arr[index], l, r);
		v.push_back(arr[index]);
		if(l == index){
			q.push(D(l + 1, r));
		}else if(r == index){
			q.push(D(l, r - 1));
		}else{
			q.push(D(l, index - 1));
			q.push(D(index + 1, r));
		}
	}
}
int main(){
	scanf("%d", &n);
	for(int i = 0;i < n;i++){
		scanf("%d", &arr[i]);
	}
	sort(arr, arr + n);
	binaryIntervals();
	for(int i = 0;i < v.size();i++){
		if(i == 0){
			printf("%d", v[i]);
		}else{
			printf(" %d", v[i]);
		}
	} 
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/a568283992/article/details/82347443