HDU1272 小希的迷宫(并查集)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63428    Accepted Submission(s): 19937


 

Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input

6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

Sample Output

Yes Yes No

PS:这题其实就是考一个并查集,判断有无回路和是否连通,注意空图也要输出Yes。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<vector>
const int maxn=1e5+5;
const int mod=1e9+7;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
int root[maxn],flog,n;
bool vis[maxn];
void inct()
{
    for(int i=1;i<maxn;i++)
        root[i]=i;
    me(vis,0);flog=0,n=0;
}
int find(int x)
{
    if(root[x]==x)
        return x;
    return root[x]=find(root[x]);
}
void un(int x,int y)
{
    int x1=find(x);
    int y1=find(y);
    if(x1!=y1)
        root[y1]=x1;
    else
        flog=1;///有回路
}
int main()
{
    int x,y;inct();
    while(~scanf("%d%d",&x,&y)&&!(x==-1&&y==-1))
    {
        if(!x&&!y)
        {
            int sum=0;
            for(int i=1;i<=n;i++)
                if(vis[i]&&root[i]==i)
                    sum++;
            if(!flog&&sum<=1)///sum<1时就是空图的情况
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
            inct();///每次结束都要初始化
        }
        else
        {
            vis[x]=vis[y]=1;///可能有些点没有输进去,所以只判断输入的点是否连通
            n=max(n,max(x,y));
                un(x,y);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/81434578