hdu 1272 小希的迷宫 (并查集)

小希的迷宫
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60206    Accepted Submission(s): 18908


Problem Description
  上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input
  输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
 

Output
  对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 

Sample Input
  6 8  5 3  5 2  6 4
  5 6  0 0

  8 1  7 3  6 2  8 9  7 5
  7 4  7 8  7 6  0 0

  3 8  6 8  6 4
  5 3  5 6  5 2  0 0

  -1 -1
 

Sample Output
  Yes
  Yes
  No

  

/**
    题目大意:
        判断题目所给的数据组成的是否是一个 “树” <连通、无环>

    判断 :“无环” 的数据结构:并查集
        并查集模板:
        #define MAX 100005
        int pre [MAX]; // 储存 一个节点的前驱节点
        int my_find (int x)
        {
            int n = x;
            while (n != pre [n]) // 找到节点x的根节点
                n = pre [n];
            int i = x, j;
            while (pre [i] != n) // 路径压缩
            {
                j = pre [i];
                pre [i] = n;
                i = j;
            }
            return n;
        }
        void my_join (int a, int b)
        {
            int n1 = my_find (a), n2 = my_find (b);
            if (n1 != n2)
                pre [n1] = n2;
        }

    判断连通:
        “无环”  &&  节点数 == 连接线 + 1
        所以现在只需要计算  ---- 节点数  ==  连线数 + 1 ?
**/

C/C++代码实现:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <stack>
#include <queue>

#define NN 100*1005

using namespace std;

int a, b, pre [NN], flag = 0, book [NN];

void init ()
{
    for (int i = 1; i < NN; ++ i)
        pre [i] = i;
    return ;
}

int my_find (int x)
{
    int n = x;
    while (n != pre [n])
        n = pre [n];
    int i = x, j;
    while (pre [i] != n)
    {
        j = pre [i];
        pre [i] = n;
        i = j;
    }
    return n;
}

bool join ()
{
    int n1 = my_find (a), n2 = my_find (b);
    if (n1 != n2)
    {
        pre [n1] = n2;
        return false ;
    }
    else
        return true ;
}

int main ()
{

    while (1)
    {
        init ();
        int cnt = 0, step = 0, my_max = -1, judge = 0;
        memset (book, 0, sizeof (book));
        while (scanf ("%d%d", &a, &b), a || b)
        {
            if (a == -1 && b == -1)
            {
                flag = 1;
                break;
            }
            book [a] = 1, book [b] = 1, ++ step;
            my_max = max (max (my_max, a), b);
            if (join ())
                judge = 1;
        }
        for (int i = 1; i <= my_max; ++ i)
        {
            if (book [i])
            {
                ++ cnt;
            }
        }
        if (flag)
            break;

        if (step + 1 == cnt && !judge)
            printf ("Yes\n");
        else if (a == 0 && b == 0 && step == 0)
            printf ("Yes\n");
        else
            printf ("No\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/GetcharZp/p/8954636.html