【POJ】1979 Black and Red(DFS)

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 41057   Accepted: 22269

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目的大概意思就是一个勇士从某一点(@)出发,只能走相邻的黑色的格子(#),而不能走红色格子(.)

代码:

//
//  main.cpp
//  DFS——红与黑.1
//
//  Created by showlo on 2018/4/19.
//  Copyright © 2018年 showlo. All rights reserved.
//
#include <stdio.h>
#include <algorithm>
using namespace std;
#define max 25
char map[max][max];
int M,N,sx,sy;
int num;
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
//void dfs()

void dfs(int x,int y){
    int i,nx,ny;
    if (x<0||x>=M||y<0||y>=N) {
       return;
    }
    
    for (i=0; i<4; i++) {
        nx=x+dx[i];
        ny=y+dy[i];
        //printf("%d %d\n",nx,ny);
        if(map[nx][ny]=='.') {
            num++;
            map[nx][ny]='#';
            dfs(nx, ny);
        }
    }
    return;
}
int main() {
    int i,j;
    while (scanf("%d %d",&N,&M)!=EOF) {
        if (M==0||N==0) {
            break;
        }
        memset(map, 0, sizeof(map));
        num=0;
        for (i=0; i<M; i++) {
            scanf("%s",map[i]);
        }
        for (i=0; i<M; i++) {
            for (j=0; j<N; j++) {
                if (map[i][j]=='@') {
                    sx=i;
                    sy=j;
                }
            }
        }
       // printf("%d %d\n",sx,sy);
        num=1;
        map[sx][sy]='#';
        dfs(sx,sy);
        printf("%d\n",num);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/biongbiongdou/article/details/80011732