POJ - 1979:Red and Black

POJ - 1979:Red and Black

来源:

标签:

参考资料:

相似题目:

题目

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

输出

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

输入样例

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

输出样例

45
59
6
13

解题思路

参考代码

#include<stdio.h>
int row,col;
const int maxn=25;
char arr[maxn][maxn];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};//方向向量
int ans;

void dfs(int x,int y)
{
    arr[x][y]='@';
    for(int i=0;i<4;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(0<=nx && nx<row && 0<=ny && ny<col && arr[nx][ny]=='.')
        {
            ans++;
            dfs(nx,ny);
        }
    }
}

int main()
{
    while(scanf("%d%d",&col,&row)==2)
    {
        if(row==0 && col==0) break;
    while(getchar()!='\n');//清除缓冲区
        int i,j;
        int posx,posy;
        for(i=0;i<row;i++)
        {
            for(j=0;j<col;j++)
            {
                arr[i][j]=getchar();
                //记录起始位置
                if(arr[i][j]=='@')
                {
                    posx=i;
                    posy=j;
                }
            }
            while(getchar()!='\n');
        }
        ans=0;//清零
        dfs(posx,posy);
        printf("%d\n",ans+1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/80467102