【POJ】1979 Red and Black (DFS)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Nicht_sehen/article/details/88862418

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 47603 Accepted: 25612

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

这个题我一开始还以为走过的路不可以重复走,然后输出一直不对,后来发现样例是可以重复走的

#include<stdio.h>
char floor[30][30];
int M,N,step=0;
int a[4]={-1,0,1,0},b[4]={0,1,0,-1};
void DFS(int x,int y)
{
	if(floor[x][y]=='#') return;
	step++;
	int nx,ny;
	floor[x][y]='#';
	for(int i=0;i<4;i++)
	{
		nx=a[i]+x;ny=b[i]+y;
		if(nx>=0&&ny>=0&&nx<N&&ny<M&&floor[nx][ny]=='.')
			DFS(nx,ny);	
	}			
}

int main()
{
	while(scanf("%d%d",&M,&N),M,N)
	{
		step=0;
		for(int i=0;i<N;i++)
			scanf("%s",floor[i]);
		for(int i =0;i<N;i++)
			for(int j=0;j<M;j++)
				if(floor[i][j]=='@')
				{
					DFS(i,j);
					break;
				}			
		printf("%d\n",step);
	}
} 

猜你喜欢

转载自blog.csdn.net/Nicht_sehen/article/details/88862418