POJ - 1979 Red and Black(java)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

package 递归和回溯;

import java.util.Scanner;

public class Main {
    static int map[][];
    static int vist[][];
    static int dx[]= {0,0,1,-1};
    static int dy[]= {1,-1,0,0};
    static int n,m;
    static int sx,sy;
    static int sum;
    static void dfs(int x,int y) {
        if(x>n||x<1||y>m||y<1)
            return ;
        for(int i=0;i<4;i++) {
            int nx=x+dx[i];
            int ny=y+dy[i];
            if(nx>n||nx<1||ny>m||ny<1||map[nx][ny]!=1||vist[nx][ny]==1) {
                continue;
            }else {
                sum++;
                vist[nx][ny]=1;
                dfs(nx,ny);
            }
                
        }
    }
    public static void main(String[] args) {
        // TODO Auto-generated method stub

        Scanner sc=new Scanner (System.in);
        for(;;) {
            m=sc.nextInt();
            n=sc.nextInt();
            if(n==0&&m==0)
                break;
            map=new int [n+3][m+3];
            vist=new int [n+3][m+3];
            sx=0;
            sy=0;
            sum=1;
            for(int i=1;i<=n;i++) {
                String s=sc.next();
                for(int j=1;j<=m;j++) {
                    
                    if(s.charAt(j-1)=='.')
                        map[i][j]=1;
                    else if(s.charAt(j-1)=='#')
                        map[i][j]=2;
                    else if(s.charAt(j-1)=='@'){
                        map[i][j]=3;
                        sx=i;
                        sy=j;
                    }
                        
                }
            }
//            for(int i=1;i<=n;i++) {
//                
//                for(int j=1;j<=m;j++) {
//                    
//                    System.out.print(map[i][j]);
//                }
//                System.out.println();
//            }
            vist[sx][sy]=1;
            dfs(sx,sy);
            System.out.println(sum);
        }
    }

}
 

猜你喜欢

转载自blog.csdn.net/weixin_43989856/article/details/107260169