POJ1979 Red and Black(DFS)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/83035649

Red and Black

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 44130   Accepted: 23912

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目大意:@表示人  . 表示黑瓷砖 #表示墙,人刚开始站在黑瓷砖上,问:人随便走可以最多可以走过多少瓷砖。

题解:很容易就想到用DFS,因为人是可以随便走的,所以只要用DFS搜索整个图,然后看递归多少次就是答案。

具体代码如下:

#include<iostream>
#include<cstring>
using namespace std;
const int N=21;
char map[N][N];
int m,n,ans;
int d[4][2]={0,1,1,0,0,-1,-1,0};
void DFS(int x,int y)
{
	ans++;
	map[x][y]='#';
	for(int i=0;i<4;i++)
	{
		int nx=x+d[i][0];
		int ny=y+d[i][1];
		if(nx<0||ny<0||nx>=n||ny>=m) continue;
		if(map[nx][ny]=='#') continue;
		DFS(nx,ny);
	}
}
int main()
{
	while(cin>>m>>n&&m+n)
	{
		memset(map,'#',sizeof(map));
		for(int i=0;i<n;i++)
			cin>>map[i];
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
				if(map[i][j]=='@')
				{
					ans=0;
					DFS(i,j);
					break;
				}
		cout<<ans<<endl;		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/83035649