POJ-1979,Red and Black(DFS)

Description:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  

Input: 

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.  

Output: 

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).  

Sample Input: 

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0 

Sample Output: 

45

59

6

13 

解题思路: 

如果说,你写搜索的题写的挺多了话,那么这道题可能你看到样例,就能猜到这是一道要用DFS的题,题目的大致意思就是说给你一个图,‘@’代表这个人初始的位置;‘#’代表红色瓷砖,表示不能走;‘.’代表黑色瓷砖,可以走。最后要计算的是遍历走完整幅图,一共可以经过多少块黑色瓷砖。 

程序代码: 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int w,h,ans;
char map[25][25];
int num1[4]={-1,1,0,0};
int num2[4]={0,0,-1,1};
void dfs(int x,int y)
{
	map[x][y]='#';
	ans++;
	for(int i=0;i<4;i++)
	{
		int tx=x+num1[i];
		int ty=y+num2[i];
		if(tx>=0&&tx<h&&ty>=0&&ty<w&&map[tx][ty]=='.')
			dfs(tx,ty);
	}
	return ;
}
int main()
{
	while(cin>>w>>h)
	{
		if(w==0&&h==0)
			break;
		ans=0;
		int x,y;
		for(int i=0;i<h;i++)
			for(int j=0;j<w;j++)
				cin>>map[i][j];
		for(int i=0;i<h;i++)
		{
			for(int j=0;j<w;j++)
			{
				if(map[i][j]=='@')
				{
					x=i;
					y=j;
				}
			}
		}
		dfs(x,y);
		cout<<ans<<endl;
	}
	return 0;
}
发布了260 篇原创文章 · 获赞 267 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/103748359