Red and Black POJ - 1979

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=21+10;
char mp[maxn][maxn];
int step[4][2]= {1,0,0,1,-1,0,0,-1};
int n,m;
int ans;
void dfs(int i,int j)
{
    ans++;
    mp[i][j]='#';
    for(int k=0; k<4; k++)
    {
        int x=i+step[k][0];
        int y=j+step[k][1];
        if(x>=0&&x<n&&y>=0&&y<m&&mp[x][y]=='.')
            dfs(x,y);
    }
}
int main()
{
    while(scanf("%d%d",&m,&n),n+m)
    {
        int x,y;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                cin>>mp[i][j];
                if(mp[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
        ans=0;
        dfs(x,y);
        cout<<ans<<endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/84594692