poj1979Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

dfs

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
char map[105][105];
int star_x,star_y;
int a[4]={1,-1,0,0};
int b[4]={0,0,1,-1};
int n,m;
int sum=1;
int judge(int x,int y)
{
	if(x>=0&&x<m&&y>=0&&y<n&&map[x][y]=='.'&&map[x][y]!='#')
	return 1;
	else
	return 0;
}
int dfs(int star_x,int star_y)
{
	int dx,dy;
	for(int i=0;i<4;i++)
	{
	
			dx=star_x+a[i];
			dy=star_y+b[i];
			if(judge(dx,dy))
			{
				sum++;
				map[dx][dy]='#';
				dfs(dx,dy);
				//map[dx][dy]='#';
			//	sum++;
			}
	}
}
int main()
{
	//int n,m;
	while(scanf("%d%d",&n,&m))
	{
	//	memset(map,0,sizeof(map));
		if(n<=0||m<=0)break;
		sum=1;
	for(int i=0;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			cin>>map[i][j];
			if(map[i][j]=='@')
			{
				star_x=i;
				star_y=j;
			}
		}
	}
//	map[star_x][star_y]='.';
	dfs(star_x,star_y);
	cout<<sum<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81327826