POJ1979-Red and Black(dfs)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13
简单的关于染色问题,dfs简单的应用
AC代码如下:

#include<stdio.h>
#include<string.h>
int sum,n,m,book[30][30];
char map[30][30];
void dfs(int x,int y)
{
	int next[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
	int tx,ty,i;
	for(i=0;i<=3;i++)
	{
		tx=x+next[i][0];
		ty=y+next[i][1];
		if(tx<0||ty<0||tx>n-1||ty>m-1)
			continue;
		if(map[tx][ty]=='.'&&book[tx][ty]==0)
		{
			sum++;
			book[tx][ty]=1;
			dfs(tx,ty);
		}
	}
	return ;
}
int main()
{
	int i,j,sx,sy,flag;
	while(scanf("%d%d",&m,&n),n!=0||m!=0)
	{
		flag=0;
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
		{
			getchar();
			for(j=0;j<m;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@') 
				{
					sx=i;
					sy=j;	
				}
			}	
		}
		sum=1;
		book[sx][sy]=1;
		dfs(sx,sy);
		printf("%d\n",sum);	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44313771/article/details/104333502