DFS:图的联通块 POJ-1979 Red and Black

Red and Black

 POJ - 1979

here is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 
'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

int m, n, sum;
char garden[105][105];
int d[4][2] = {
	{0, -1},
	{1, 0},
	{0, 1},
	{-1, 0},
};

void dfs(int x, int y)
{
	garden[x][y] = '#';
	sum++;

	for (int i = 0; i < 4; i++){
		int nx = x + d[i][1];
		int ny = y + d[i][0];
		if(0<=nx && nx<n && 0<=ny && ny<m && garden[nx][ny]=='.')
			dfs(nx, ny);
	}
}

int main(void)
{
	while(~scanf("%d%d", &m, &n) && m+n){
		getchar();	
		memset(garden, 0, sizeof(garden));
	
		for (int i = 0; i < n; i++){
			for (int j = 0; j < m; j++)
				scanf("%c", &garden[i][j]);
			getchar();
		}

		sum = 0;
		for (int i = 0; i < n; i++)
			for (int j = 0; j < m; j++)
				if (garden[i][j] == '@')
					dfs(i, j);
	
		cout << sum << endl;
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/mofadiyu/article/details/81234429