POJ-1979 Red and Black

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 30661   Accepted: 16688

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6

13

介个题就是让你求一下他能走多少个".",一个小迷宫,运用DFS,再加上一个记录数组就行啦,不过这个不能在回溯的时候将已经遍历过的变回原值。

代码在下边:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits> 
#include <queue>
#define M 10000
using namespace std;
char map[25][25];
bool vis[25][25];
int fx[4]={1,-1,0,0};
int fy[4]={0,0,1,-1};
int ans,w,h;
void f(int x,int y)
{
	for(int i=0;i<4;i++)
	{
		if(map[x+fx[i]][y+fy[i]]=='.'&&vis[x+fx[i]][y+fy[i]]==false&&x+fx[i]>=0&&x+fx[i]<h&&y+fy[i]>=0&&y+fy[i]<w)
		{
			vis[x+fx[i]][y+fy[i]]=true;
			ans++;
			f(x+fx[i],y+fy[i]);
		}
	}
}
int main()
{
	while(~scanf("%d%d",&w,&h)&&w||h)
	{
		int x,y;
		memset(vis,false,sizeof(vis));
		for(int i=0;i<h;i++)
		{
			getchar();
		    for(int j=0;j<w;j++)
		    {
		    	scanf("%c",&map[i][j]);
		    	if(map[i][j]=='@')
				{
		    		vis[i][j]=true;
		    		x=i;y=j;
				}
			}
		}
		ans=0;
		f(x,y);
		printf("%d\n",ans+1);
	}
	return 0;
}


扫描二维码关注公众号,回复: 13479685 查看本文章

猜你喜欢

转载自blog.csdn.net/Poseidon__ming/article/details/52053966