poj-1979 red and black(搜索)

Time limit1000 ms

Memory limit30000 kB

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意:红色和黑色的地砖,只能走黑色的地砖,问最多可以走几块地砖
题解:dfs
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
using namespace std;
#define PI 3.14159265358979323846264338327950
#define INF 0x3f3f3f3f3f3f3f3f;

char a[25][25];
int vis[25][25];
int m,n,st,en,sum;

void dfs(int x,int y)
{
    a[x][y]='#';
    sum++;
    if(x-1>=0 && a[x-1][y]=='.')
        dfs(x-1,y);
    if(x+1<n && a[x+1][y]=='.')
        dfs(x+1,y);
    if(y-1>=0 && a[x][y-1]=='.')
        dfs(x,y-1);
    if(y+1<m && a[x][y+1]=='.')
        dfs(x,y+1);
}

int main()
{
    while(scanf("%d %d",&m,&n) && (m||n))
    {
        sum=1;
        int i,j;
        memset(vis,0,sizeof(vis));
        for( i=0;i<n;i++)
            for(j=0;j<m;j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                {
                    st=i;
                    en=j;
                }
            }
        int x=st,y=en;
        a[x][y]='#';
        if(x-1>=0 && a[x-1][y]=='.')
            dfs(x-1,y);
        if(x+1<n && a[x+1][y]=='.')
            dfs(x+1,y);
        if(y-1>=0 && a[x][y-1]=='.')
            dfs(x,y-1);
        if(y+1<m && a[x][y+1]=='.')
            dfs(x,y+1);
        printf("%d\n",sum);
    }
}

猜你喜欢

转载自www.cnblogs.com/smallhester/p/9499285.html