A - Red and Black【BFS/DFS】

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

bfs和dfs都可以做

bfs代码:

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int N=1005;
int n,m;
char ma[N][N];
bool vis[N][N];
int ans;
struct node {
	int x,y;
//	int sum;
//	friend bool operator < (node a,node b){
//		return a.sum<b.sum;
//	}
};
int dir[4][2]= {1,0,-1,0,0,1,0,-1};
void bfs(int s,int e) {
	ans=0;
//	priority_queue<node>que;
	queue<node>que;
	memset(vis,0,sizeof(vis));
	node u,v;
	u.x=s;
	u.y=e;
//	u.sum=0;
	que.push(u);
	vis[s][e]=1;
	while(!que.empty()) {
		u=que.front();
		que.pop();
		for(int i=0; i<4; i++) {
			v.x=u.x+dir[i][1];
			v.y=u.y+dir[i][0];
			if(v.x>=0&&v.x<n&&v.y>=0&&v.y<m&&vis[v.x][v.y]==0&&ma[v.x][v.y]!='#') {
				//	v.sum=u.sum+1;
				que.push(v);
				vis[v.x][v.y]=1;
				ans++;
			}
		}
	}
}
int main() {
	memset(ma,0,sizeof(ma));
	while(cin>>m>>n,m||n) {
		for(int i=0; i<n; i++)
			cin>>ma[i];
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++) {
				if(ma[i][j]=='@') {
					bfs(i,j);
					break;
				}
			}
		cout<<ans+1<<endl;
	}

	return 0;
}

dfs代码:

#include<bits/stdc++.h>
using namespace std;
const int N=1005;
int m,n;
int ans;
char ma[N][N];
bool vis[N][N];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y)
{
	vis[x][y]=1;
	for(int i=0;i<4;i++)
	{
		int dx=x+dir[i][0];
		int dy=y+dir[i][1];
		if(dx>=0&&dx<n&&dy>=0&&dy<m&&vis[dx][dy]==0&&ma[dx][dy]!='#')//剪枝 
		{
			vis[dx][dy]=1;
			dfs(dx,dy);
			ans++;
		}
		
	}
}
int main()
{
	while(cin>>m>>n,m||n)
	{
		ans=1;//起点 
		memset(vis,0,sizeof(vis));
		memset(ma,0,sizeof(ma));
		for(int i=0;i<n;i++)
		cin>>ma[i];
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++)
			if(ma[i][j]=='@')
			{
				dfs(i,j);
				break;
			}
			
		}
		cout<<ans<<endl;
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81333222