【hdoj 1272】小希的迷宫

小希的迷宫
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36409 Accepted Submission(s): 11142


Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1
Sample Output
Yes
Yes
No

解题思路:所有的点都连通并且无回路输出yes,其余情况输出no

code1:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <set>
using namespace std;
set<int>node;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF&&(a!=-1&&b!=-1))
    {
        if(a==0&&b==0)
            printf("Yes\n");
        int sum=1;
        node.insert(a);
        node.insert(b);
        while(scanf("%d%d",&a,&b)!=EOF&&(a||b)){
            sum++;
            node.insert(a);
            node.insert(b);
        }
        if(node.size()-1==sum)
            printf("Yes\n");
        else
            printf("No\n");
        node.clear();
    }
    return 0;
}


code2:

并查集的方法解决

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <set>
using namespace std;
int pre[100010];
int v[100010];
int Find(int x)
{
    while(x != pre[x])
        x = pre[x];
    return x;
}
void unin(int x,int y)
{
    x = Find(x);
    y = Find(y);
    if(x > y)
        pre[x] = y;
    else if(x < y)
        pre[y] = x;
}
int main()
{
    int a,b;
    int flag,total;
    while(scanf("%d%d",&a,&b)!=EOF&&(a != -1&&b != -1))
    {
        if(a == 0&&b == 0)
            printf("Yes\n");
        memset(v,0,sizeof(v));
        for(int i = 1;i < 100005;i++)
            pre[i] = i;
        unin(a,b);
        v[a] = 1;
        v[b] = 1;
        flag = 1;
        total = 1;
        while(scanf("%d%d",&a,&b)!=EOF&&(a||b)){
            if(!v[a]){
                total++;
                v[a] = 1;
            }
            if(!v[b]){
                total++;
                v[b] = 1;
            }
            if(Find(a)==Find(b))
                flag = 0;
            else
                total--;
            unin(a,b);
        }
        if(flag&&total==1)
            printf("Yes\n");
        else
            printf("No\n");

    }
    return 0;
}





猜你喜欢

转载自blog.csdn.net/nininicrystal/article/details/48474049